Go to previous topic
Go to next topic
Last Post 01/02/2018 8:00 AM by  PD
Security violation
 2 Replies
Author Messages
PD
Systems Integration Specialist
Private
Advanced Member
(62 points)
Advanced Member
Posts:32


Send Message:

--
12/29/2017 4:35 PM

    I am using a LwsnTxn and WebRun node for a PR295 job. I then reference the bldxffiles utility to convert the PR295.prt to a csv file. The csv is not being created because the .prop and .grp files are not being generated neither from the job or the utility. Might anyone be knowledgeable on how to generate the .prop and .grp files with the prt job or ?

     

    I am using this command:

    bldxffiles -SCp 382396 D:\lsenv\law/print/INFORBC_382396/pr295-ju/1  PR295.prt

     

     

    I am getting this error msg:

    Starting bldxffiles:

    bldxffiles input param summary:

    UserName is: 382396

    RptUser Name is: NT0000002c

    Single Print File is: PR295.prt

    PrintFi (and 311 additional characters)

    Command error output: Security Violation

    D:\lsenv\gen/bin/rptgen: Error Encountered In Execution

     

    SysCommand5560_errorOutput = Security Violation

    D:\lsenv\gen/bin/rptgen: Error Encountered In Execution

     

    System command error: command returned error code 1

    Variables in Process:

    lastOutputData =

    Starting bldxffiles:

     

    bldxffiles input param summary:

    UserName is: 382396

    RptUser Name is: NT0000002c

    Single Print File is: PR295.prt

    PrintFilePath is: D:/lsenv/law/print/INFORBC_382396/pr295-ju/1

    Using Input params for Build Settings:

    Building CSV file

     

    Using Local Properties and Grp Files

    Creating Local .grp file with rptgen

    Security Violation

    D:\lsenv\gen/bin/rptgen: Error Encountered In Execution

     

    Thanks

    Carl.Seay
    Private
    Private
    Veteran Member
    (310 points)
    Veteran Member
    Posts:106


    Send Message:

    --
    12/29/2017 5:24 PM
    By default the PFI services run as System on LSF, so when running Lawson commands from IPA it uses the system user (lsenv_system). You can either add security roles to this user (probably not recommended), or open an incident and ask Cloud Ops to setup the PFI services to run as an actual user with security. Command line utilities are in the ENV security profile.
    PD
    Systems Integration Specialist
    Private
    Advanced Member
    (62 points)
    Advanced Member
    Posts:32


    Send Message:

    --
    01/02/2018 8:00 AM

    Thanks, Carl for your input. I've asked cloud for the mod and awaiting their feedback...will keep you posted

     

    Cloud made the fix and I am all set.....Thanks again Carl



    ---