PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 05/31/2017 8:37 AM by  WadeYohanek
Discount Date - 810
 4 Replies
Sort:
You are not authorized to post a reply.
Author Messages
WadeYohanek
EDI Manager
Private
Basic Member
(11 points)
Basic Member
Posts:5


Send Message:

--
05/23/2017 11:27 AM

    We are getting an error from Stryker because they are sending a Discount Date on their invoices but there is no discount provided. Is anyone else familiar with this? I have not been able to locate anything for ED40 that could ignore this date.

     

    ITD^03^4^0^^0^20170615^30^^^^^Net 30 Days

     

    Jeremy
    Private
    Private
    Veteran Member
    (204 points)
    Veteran Member
    Posts:82


    Send Message:

    --
    05/24/2017 10:09 AM
    Without seeing the full 810 EDI file, it's hard for me to offer much advise. I often use a program called EDI Notepad that helps out a LOT. It will give me the errors with the file and then I can manipulate the file to get it set properly. This helps me work with the vendor that is passing the file (or our EDI VAN) and they can often add/remove fields I request.
    WadeYohanek
    EDI Manager
    Private
    Basic Member
    (11 points)
    Basic Member
    Posts:5


    Send Message:

    --
    05/25/2017 11:45 AM

    Apologize ... I did misspeak. They are sending us a discount percentage without a discount date, not the other way around. The segment in question from what I can tell is the ITD segment I copied, but I have attached the full EDI file.

     

    ITD element 3 should be the discount percent and element 4 should be a date. In this case, I have 0 and blank.

    ITD^03^4^0^^0^20170615^30^^^^^Net 30 Days

     

    Should GHX be stripping the '0' discount percent before sending, or is there a piece of the AP setup that causes this to be an error?

    Attachments
    Jeremy
    Private
    Private
    Veteran Member
    (204 points)
    Veteran Member
    Posts:82


    Send Message:

    --
    05/27/2017 10:45 AM
    As far as I can tell, from EDI standards, it should not be required. Where are you seeing the error? If it's in Lawson, what is the error stating?
    WadeYohanek
    EDI Manager
    Private
    Basic Member
    (11 points)
    Basic Member
    Posts:5


    Send Message:

    --
    05/31/2017 8:37 AM

    That's what I thought too. I've attached the screenshot our AP staff sent me.

    Attachments
    You are not authorized to post a reply.