PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 09/07/2017 11:28 AM by  PFlowNerd
Create PO via PO23.1 in PF
 16 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Lynne
Application Specialist
Covenant HealthCare
Veteran Member
(283 points)
Veteran Member
Posts:115


Send Message:

--
10/02/2012 2:55 PM
    I am attempting to create a PO via PO23.1 in my PF.  I would prefer to do it this way as opposed to running a PO100 job from PF.  My problem is that I have to inquire on the PO23.1 before doing an 'Add'.  I have read some posts about this same problem on different forms and have not been able to get mine to work.  On one it said that you had to have _EVT=CHG.  I've tried that and _EVT=ADD.  I also saw where you had to have the hidden key, _HK, set.  I also tried that but am not sure I have all the fields.  I only concatenate procurement group, doc# and origin fields.  That is all I need to inquire, but do I need company etc.

    Anyway, I'm wondering if anyone has done this that could help me.  Here is the transaction string as I have it now.  Any suggestions would be appreciated.  Maybe I should stick with running PO100 even though this would be quicker and more efficient.

    _PDL=TEST&_TKN=PO23.1&_EVT=CHG&_RTN=DATA&_LFN=ALL&_TDS=IGNORE&FC=A&_HK=CHS0080148RQ&SAVE-FC=A&PIF-PROCURE-GROUP=CHS&PIF-COMPANY=0100&FIL-SOURCE-DOC=0080148&SAVE-SOURCE-DOC=0080148&FIL-ORIGIN-CD=RQ&PCR-VENDOR=%20%20%20100005&PCR-BUYER-CODE=PMW&SELECT-ALL=Y&PCR-DFLT-DL-DATE=10/02/2012&_DELIM=%09&_IGNREQD=true&_OUT=XML&_EOT=TRUE
    David Williams
    Private
    Private
    Veteran Member
    (3040 points)
    Veteran Member
    Posts:1024


    Send Message:

    --
    10/08/2012 3:01 PM
    I was able to get this to work using the following AGS call.

    //_PDL=QA&_TKN=PO23.1&_EVT=CHG&_RTN=DATA&_LFN=ALL&_TDS=IGNORE&FC=A&PIF-PROCURE-GROUP=LHS&PIF-COMPANY=200&FIL-SOURCE-DOC=1324173&FIL-ORIGIN-CD=RQ&PCR-VENDOR=23685&PCR-BUYER-CODE=PPR&PCR-DFLT-DL-DATE=20121008&SELECT-ALL=Y&_DELIM=%09&_OUT=XML&_EOT=TRUE
    David Williams
    Lynne
    Application Specialist
    Covenant HealthCare
    Veteran Member
    (283 points)
    Veteran Member
    Posts:115


    Send Message:

    --
    10/11/2012 1:10 PM
    Hi David,
    Thanks for trying to help me. I tried using your call and I get the "Must Inquire before using this function code" return msg. I wonder why yours works. Here's my call:

    _PDL=&_TKN=PO23.1&_EVT=CHG&_RTN=DATA&_LFN=ALL&_TDS=IGNORE&FC=A&PIF-PROCURE-GROUP=CHS&PIF-COMPANY=&FIL-SOURCE-DOC=&FIL-ORIGIN-CD=RQ&PCR-VENDOR=&PCR-BUYER-CODE=&PCR-DFLT-DL-DATE=&SELECT-ALL=Y&_DELIM=%09&_OUT=XML&_EOT=TRUE
    David Williams
    Private
    Private
    Veteran Member
    (3040 points)
    Veteran Member
    Posts:1024


    Send Message:

    --
    10/11/2012 1:48 PM
    Your call appears to missing several values - is this a copy and paste issue? You're missing the requisition number, vendor, buyer, etc.
    David Williams
    Gopireddy
    Basic Member
    (18 points)
    Basic Member
    Posts:6


    Send Message:

    --
    10/11/2012 2:05 PM
    Your call missing values like Product line etc.....
    Lynne
    Application Specialist
    Covenant HealthCare
    Veteran Member
    (283 points)
    Veteran Member
    Posts:115


    Send Message:

    --
    10/11/2012 2:17 PM
    Not sure how I got the one I posted. Here's how my call really looks:

    _PDL=&_TKN=PO23.1&_EVT=CHG&_RTN=DATA&_LFN=ALL&_TDS=IGNORE&FC=A&PIF-PROCURE-GROUP=CHS&PIF-COMPANY=&FIL-SOURCE-DOC=&FIL-ORIGIN-CD=RQ&PCR-VENDOR=&PCR-BUYER-CODE=&PCR-DFLT-DL-DATE=&SELECT-ALL=Y&_DELIM=%09&_OUT=XML&_EOT=TRUE
    Lynne
    Application Specialist
    Covenant HealthCare
    Veteran Member
    (283 points)
    Veteran Member
    Posts:115


    Send Message:

    --
    10/11/2012 2:18 PM
    Well, that is very strange. When I paste it in, it looks fine and when I submit it, it takes all the fields out.
    David Williams
    Private
    Private
    Veteran Member
    (3040 points)
    Veteran Member
    Posts:1024


    Send Message:

    --
    10/11/2012 2:27 PM
    Do what I did - put the comment tags before your call before click submit. //
    David Williams
    Lynne
    Application Specialist
    Covenant HealthCare
    Veteran Member
    (283 points)
    Veteran Member
    Posts:115


    Send Message:

    --
    10/11/2012 2:36 PM

    For some reason it strips my variables out when I submit my reply.  Maybe it doesn't like the <>??
    Here is the call from my WU which shows the values:

    Transaction Call String: _PDL=TEST&_TKN=PO23.1&_EVT=CHG&_RTN=DATA&_LFN=ALL&_TDS=IGNORE&FC=A&PIF-PROCURE-GROUP=CHS&PIF-COMPANY=0100&FIL-SOURCE-DOC=0080168&FIL-ORIGIN-CD=RQ&PCR-VENDOR=%20%20%20100005&PCR-BUYER-CODE=PMW&PCR-DFLT-DL-DATE=20121011&SELECT-ALL=Y&_DELIM=%09&_OUT=XML&_EOT=TRUE%20

    Error while Executing activity : Type=AGS, ActivityName=Transaction940, ActivityId=AGS13, WorkUnit=2864 Date:10/11/2012 Time:14:02:37.647

    ErrorLog in Process : ReqAppOR_V37 Workunit : 2864, ActivityType=AGS, ActivityName=Transaction940, ActivityId=AGS13 Date:10/11/2012 Time:14:02:37.647

    AGS error: Must Inquire before using this function code

    John Henley
    Private
    Private
    Senior Member
    (9620 points)
    Senior Member
    Posts:3224


    Send Message:

    --
    10/11/2012 2:41 PM
    URLs and XML get hammered when they are posted. You can either wrap in <code></code> tags or post as an image..
    Thanks for using the LawsonGuru.com forums!
    John
    David Williams
    Private
    Private
    Veteran Member
    (3040 points)
    Veteran Member
    Posts:1024


    Send Message:

    --
    10/11/2012 4:54 PM
    Nothing stands out as an obvious issue - the AGS looks okay to me. Are you sure you're testing this against the server and product line where this requisition actually exists?
    David Williams
    Lynne
    Application Specialist
    Covenant HealthCare
    Veteran Member
    (283 points)
    Veteran Member
    Posts:115


    Send Message:

    --
    10/12/2012 6:16 AM
    Yes, the server and pdl match where the req exists. I don't know how the req would trigger the PF if the pdl and server weren't matching. The test server is the only place this PF lives.
    John Henley
    Private
    Private
    Senior Member
    (9620 points)
    Senior Member
    Posts:3224


    Send Message:

    --
    10/12/2012 10:06 AM
    Lynne, what apps version are you running? What is the version of PO23PD?
    There are some patches related to that issue, so depending on which version of PO23 you have installed, that would account for why it works for David but not for Lynne.
    Look for issue number 172604, and fix was issued for 9.0.0 apps as CTP 54006, and applies to PO23PD v 132.1.15.1.33 and later.
    Thanks for using the LawsonGuru.com forums!
    John
    Lynne
    Application Specialist
    Covenant HealthCare
    Veteran Member
    (283 points)
    Veteran Member
    Posts:115


    Send Message:

    --
    10/12/2012 10:44 AM
    My version is 132.1.58.1.28 and I think it already includes that patch. Maybe older versions let you do this and shouldn't have. It does seem like I should be inquiring because that's what pulls the lines in to add to the PO. If it did not give me this error and did the add, it seems like there wouldn't be any lines on my PO.
    John Henley
    Private
    Private
    Senior Member
    (9620 points)
    Senior Member
    Posts:3224


    Send Message:

    --
    10/12/2012 11:08 AM
    The inquire is implied and is done internally when you use _EVT=CHG
    You might want to try either leaving that parameter off, or using _EVT=ADD and see what the results are.
    Thanks for using the LawsonGuru.com forums!
    John
    Lynne
    Application Specialist
    Covenant HealthCare
    Veteran Member
    (283 points)
    Veteran Member
    Posts:115


    Send Message:

    --
    10/15/2012 9:04 AM
    I tried leaving the parameter off and using ADD. I get the same results.
    PFlowNerd
    Sr. Technical Analyst
    Private
    New Member
    (3 points)
    New Member
    Posts:1


    Send Message:

    --
    09/07/2017 11:28 AM

    Has anyone been able to get past this issue?  This transaction worked fine for me in  V9 - but in V10 I get the same error.... here is my call:

    _PDL=PROD10&_TKN=PO23.1&_EVT=CHG&_RTN=DATA&_LFN=ALL&_TDS=IGNORE&FC=C&PIF-PROCURE-GROUP=1&PIF-COMPANY=xxxx&PCR-PO-NUMBER=xxxxxxxxxxx&FIL-ORIGIN-CD=RQ&FIL-SOURCE-DOC=xxxxxxx&LINE-FCr0=S&PIF-ITEMr0=xxxxxxxx&_DELIM=%09&_OUT=XML&_EOT=TRUE


    And my output:

     Must Inquire before using this function code
            206
            001
            TC

    You are not authorized to post a reply.