PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 11/04/2017 8:47 AM by  David Williams
PATCH web API triggered from IPA flow
 3 Replies
Sort:
You are not authorized to post a reply.
Author Messages
brox07
Systems Developer
Private
Basic Member
(22 points)
Basic Member
Posts:8


Send Message:

--
10/30/2017 4:35 PM

    I'm trying to run a web API, using the PATCH method, that our web dev team developed.  I set up a webrun node with the information that I needed but it's returning an "Invalid HTTP method: PATCH" error.  I tried using "POST" with "X-HTTP-Method-Override: PATCH" in the Post String with no luck.  Has anyone had any experience with this?  Any information would be greatly appreciated.  

    David Williams
    Private
    Private
    Veteran Member
    (3061 points)
    Veteran Member
    Posts:1031


    Send Message:

    --
    11/01/2017 3:02 PM
    Have you looked at the Web Service APIs at https://LandmarkURL/hcm/soap/doco/rest/raw/home
    David Williams
    Tim Cochrane
    Private
    Private
    Veteran Member
    (450 points)
    Veteran Member
    Posts:154


    Send Message:

    --
    11/03/2017 12:48 PM
    DW - have you gotten that doco link to work?? I've tried it with a few LM v10 clients...and all I ever get is a 404...so I assumed it only works in LM 11??
    Tim Cochrane - Principal LM/IPA Consultant
    David Williams
    Private
    Private
    Veteran Member
    (3061 points)
    Veteran Member
    Posts:1031


    Send Message:

    --
    11/04/2017 8:47 AM
    Tim - you may be right. I’ve only tried in Landmark v11. It’s coming to ION soon too.
    David Williams
    You are not authorized to post a reply.