PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 02/05/2019 11:44 AM by  LauraPat
Strange job scheduler issue
 2 Replies
Sort:
You are not authorized to post a reply.
Author Messages
LauraPat
Sr. Application Engineer
Private
Advanced Member
(52 points)
Advanced Member
Posts:26


Send Message:

--
02/05/2019 10:38 AM
    Had an issue last night that in 25 years working with Lawson I've never seen.  I had a batch job (that's been running for 3 years without issue), that has 66 steps.  On step 26 it failed and went into needs recovery.  Only error msg as "Stopped on Exit 1". Any attempt to recover the job resulted it in going back into needs recovery immediately.  Tried putting a trace on the program to see where it was failing and it wasn't getting into the program.  Appears to be a hiccup in the job scheduler and it "lost it's place".  I had to create another job, with all the remaining steps and run that and that worked fine.  Has anyone seen anything like this happen in the job scheduler?  We are on Version 10 on-premise.  Thx
    John Henley
    Private
    Private
    Senior Member
    (9692 points)
    Senior Member
    Posts:3248


    Send Message:

    --
    02/05/2019 11:28 AM
    I have seen it a lot recently on LSF 10 on windows.
    Thanks for using the LawsonGuru.com forums!
    John
    LauraPat
    Sr. Application Engineer
    Private
    Advanced Member
    (52 points)
    Advanced Member
    Posts:26


    Send Message:

    --
    02/05/2019 11:44 AM
    Wow - that's very disconcerting.  We are on Linux but if the issue is occurring on Windows, it's not all that surprising that we are seeing it.  I've opened a ticket with Infor but I'm not sure they are going to be much help because even though it is clearly a job scheduler issue - the programs being run are custom programs ..  But this is very ugly when it happens and I hope this doesn't mean it is going to start happening more often.
    You are not authorized to post a reply.