PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 9/5/2012 4:31 PM by  Roger French
Drill around on Accounts in PR35 and others, not working
 1 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Roger French
Private
Private
Veteran Member
(1304 points)
Veteran Member
Posts:542


Send Message:

--
9/5/2012 4:24 PM
    I've got LS9 Security turned on.
    Windows env, 2008, SQL, Env 9.0.1.5, Apps 9.0.1.5

    So I've got a security role where several screens are invoked which have the Accounts and Accounting unit on them, such as the PR35.1.

    Within the role is a security class with a rule which allows full access to all of the files required by PR35.1 drill arounds, such as EMPLOYEE, GLNAMES, etc.

    Within the security class I've also got an element group rule:

    user.attributeContains('CompanyControl',lztrim(COMPANY))&&user.attributeContains('ProcessLevelControl',trim(PROCESS_LEVEL))  then ALL ACCESS
    else
    NO ACCESS

    I use this rule for the EMPLOYEE table really, and nothing else. The GLNAMES rule is wide open with full access. So when I launch the PR35 for the user I can get the correct employees on the Employee drill around but I the accounts and all of the accounting drill arounds return zero/no records found (of course, we have hundreds of accounts).










    Roger French
    Private
    Private
    Veteran Member
    (1304 points)
    Veteran Member
    Posts:542


    Send Message:

    --
    9/5/2012 4:31 PM
    (Sorry for the double posting, this forum doesn't appear to allow editing of posts after they've been posted and I can't find out how to delete the post after it's been posted.)

    I've got LS9 Security turned on.
    Windows env, 2008, SQL, Env 9.0.1.5, Apps 9.0.1.5

    So I've got a security role where several screens are invoked which have the Accounts and Accounting unit on them, such as the PR35.1.

    Within the role is a security class with a rule which allows full access to all of the files required by PR35.1 drill arounds, such as EMPLOYEE, GLNAMES, etc.

    Within the security class I've also got an element group rule:

    user.attributeContains('CompanyControl',lztrim(COMPANY))&&user.attributeContains('ProcessLevelControl',trim(PROCESS_LEVEL)) then ALL ACCESS
    else
    NO ACCESS

    I use this rule for the EMPLOYEE table really, and nothing else. The GLNAMES rule is wide open with full access. So when I launch the PR35 for the user I can get the correct employees on the Employee drill around but the accounts and all of the accounting drill arounds return zero/no records found (of course, we have hundreds of accounts).

    I have logging turned ON for the user and even the lase log file says that GLNAME access is granted. Here is a sniped of the log file.

    2012-09-05 13:13:40 com.lawson.lawsec.default.FINE com.lawson.lawsec.author.runtime.LawsonSecurityRuntimeImpl.isTableSecured()
    USER: xxxxxxxxx
    finished for tableName=GLNAMES, actionCode=I: ACCESS ALLOWED

    But still no accounts will appear in the drop down. I've checked everything multiple times, including ensuring the obvious to make sure the company value is entered in PR35.

    We've stopped and started everything up multiple times and still the issue appears.

    When I take out the Element Group rule, then the drop down on Accounts do work. But I need the Element Group rule for other things. Furthermore the element group rule isn't even associated with any screen or table except EMPLOYEE, so why should it be affecting GLNAMES??

    Has anyone got any clue to what's going on here?

    Thank you in advance,
    Roger
    You are not authorized to post a reply.