PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 03/19/2015 6:39 PM by  Dave Amen
Printers in Portal and LS Security
 3 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Roger French
Private
Private
Veteran Member
(1266 points)
Veteran Member
Posts:522


Send Message:

--
06/28/2011 12:47 PM
    I'm doing some work with printer issues in Lawson portal. Some users are using LS Security and when they're in Portal and running jobs such as CU201, when they actually want to print the report, the report shows up in print manager find, and it displays fine on screen, but when they want to send to printer and click on the drop down of the Printer field to list all of the printers, NO printers appear. 

    These users DO have the BatchRole in their LS Security. I've checked the BatchRole for GEN/LGN profiles and the Application profile and they all seem fine. They do have access to the PRINTER files and all of the Printer-related files in GEN.

    When they do not use LS Security, all of the printers appear in the jobs' drop down.

    My thought was that the printers also have to of course, be defined on the operating system (Windows or AIX/HP) of the server where Lawson is installed, correct? Since the printers do show up when using LAUA security, why are they not showing up in Portal when using LS Security?

    Thank you in advance,
    Roger
    Roger French
    Private
    Private
    Veteran Member
    (1266 points)
    Veteran Member
    Posts:522


    Send Message:

    --
    06/28/2011 3:02 PM
    Thanks Dave A. for the heads up and reminder. Had a slight case of brain fog.

    Anyways I added the specific printers listed in the Printers Securable type and the printers are now appearing in the drop downs.

    Much appreciated,
    Roger
    Greg
    Systems Analyst
    Saint Joseph's Hospital
    Basic Member
    (12 points)
    Basic Member
    Posts:4


    Send Message:

    --
    03/19/2015 2:34 PM

    Hi Roger,

     

    I am migrating from LAUA to LS9 and I am having the same issue you describe.  All my LAUA security users can see all our printers but anyone I setup with LS9 Security cannot see any printers in the search drill down?

     

    Do you recall what you did  to fix this issue?

     

    BTW, I am training myself to do LS9 so my breath of knowledge in this area is still pretty minimal, although all my requisitioner's are using LS9 with just this one last issue to resolve, at least that is all I know of.

    Thanks

    Greg

    Dave Amen
    Private
    Private
    Veteran Member
    (173 points)
    Veteran Member
    Posts:61


    Send Message:

    --
    03/19/2015 6:39 PM
    Hi Greg,
    I have a suggestion. Do this:

    In the ENV profile, create a SecClass named "Printers".
    Double-click on that SecClass, Add a rule, change Securable Types to Printers, and Grant All Access to all of your printers (which should appear in the list).
    Attach your new "Printers" SecClass to your BatchRole.

    Everyone should now be able to see all of the printers.
    Are you familiar with setting up each user's default printer in the Environment screen (3rd screen of the user setup)?

    Feel free to call me if anything here doesn't make sense!

    Best regards,
    Dave
    (303) 773-3535
    You are not authorized to post a reply.