PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 10/14/2017 7:41 AM by  Char
LBI Schedule Disappear Randomly
 8 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Dave Curtis
HRIS Lead
University of Maryland Medical System
Veteran Member
(292 points)
Veteran Member
Posts:102


Send Message:

--
09/11/2017 9:30 AM
    Over a year ago we started having this random issue with LBI report schedules randomly disappearing. We have tried to find a reason why and tie it to some event but have not been able to.

    What is additionally head scratching is that not ALL of the schedule is gone. If I look in the table that has the schedule triggers (ejs_triggers: This is the info on the second part of the schedule with delivery info etc.) I will find the schedule but the actual schedule in ejs_cron_triggers is gone. So it is deleted from the cron triggers so it will not run and if you look in the LBI application it is gone completely.

    We have contacted Infor and worked with some technical resources to try and find a cause but have had no success in finding a reason. :crazy:

    Has anyone else experienced this? If so - have you found any cause of it?

    Thanks
    Dave
    Tags: Reports, LBI, Schedules, Infor, Reporting, CRON
    Greg Moeller
    Private
    Private
    Veteran Member
    (3873 points)
    Veteran Member
    Posts:1377


    Send Message:

    --
    09/11/2017 9:38 AM
    Dave: We've been having the same issue here. Seems to have been going on for years now... Like you, we have also reported it to Infor. Infor did some investigation and had us upgrade LBI. We assumed that would fix things, but no. It seems to ONLY happen (to us) on the 1st of every month if it happens at all.
    Glad to know that we aren't alone, but it seems that I don't have any other suggestions for you either.
    NatalieD
    Analyst, Report Writer
    ProMedica
    Advanced Member
    (81 points)
    Advanced Member
    Posts:41


    Send Message:

    --
    09/11/2017 9:47 AM
    Hi Dave - No, you are not alone! We have been experiencing this issue as well. We upgraded to v10 end of 2016 but experienced this in v9. We have scheduled reports that run monthly and we often find schedules that do not produce an instance and usually the schedule has dropped as well. Working with Infor, we've heard that they are aware and are currently working on the issue. We've discovered it appears that if someone deletes a schedule or a historical instance, it will cause another random schedule or historical instance to be deleted. So just recently we've announced to our LBI admins we have to no longer delete anything until further notice - instead either rename the historical instance to "do not use" or set the schedule to expire. It's a temporary workaround. We try to report error logs as much as possible. We basically rely on end users or manual checks to see what's dropped as I've not learned of anything Infor offers to be proactive with this problem. Just waiting for them to finally figure it out.
    Dave Curtis
    HRIS Lead
    University of Maryland Medical System
    Veteran Member
    (292 points)
    Veteran Member
    Posts:102


    Send Message:

    --
    09/21/2017 2:57 PM
    It is always nice to find that we are not alone. Not that I wish issues on others - but knowing it is not just us makes it a bit "easier" to work through.

    I appreciate the responses. Interesting about your point Greg about the 1st of the month. I have tried to keep a log of when we see it but it is very difficult unless I check all reports with schedules every day to know when it actually happens.

    Natalie - your discovery is very interesting to me actually - we have an archive process that deletes items that are older than 90 days, this is automated and is run daily. It could easily be something similar.

    I have put together a monitor that looks for schedules on the ers_distributionoptions table that do not have a matching record on the ejs_triggers to try and catch them when they happen.

    Driving me crazy I admit it... (has for a couple years)...
    Greg Moeller
    Private
    Private
    Veteran Member
    (3873 points)
    Veteran Member
    Posts:1377


    Send Message:

    --
    09/21/2017 3:01 PM
    We actually tried to set up a SmartNote to notify us when the table changes... but I don't think that we've been very successful with that endeavor.
    Dave Curtis
    HRIS Lead
    University of Maryland Medical System
    Veteran Member
    (292 points)
    Veteran Member
    Posts:102


    Send Message:

    --
    09/21/2017 4:02 PM
    Here is a SQL query that I put together that finds schedules that are on the distributionoptions but not on ejs_triggers. Sometimes it will give a false positive if someone creates a schedule that is run just one time and has an end date to make sure it is not run again. I created a Smart Note that uses this SQL query and is run daily and any time it has new records it is sent to me. Not sure if it would be helpful or not but here it is...
    _____________________________

    SELECT *
    FROM (SELECT DISTINCT sch.reportid
    ,sch.schedulename
    ,sch.outputtype
    ,sch.emailenabled
    ,sch.msgformat
    ,sch.recipients
    ,sch.mimetype
    ,sch.networkdrive
    ,sch.subfolder
    ,sch.networkdriveenabled
    ,rpt.status
    ,tr.trigger_name
    ,tr.trigger_group
    ,tr.job_name
    ,tr.job_group
    ,tr.is_volatile
    ,tr.description
    ,tr.next_fire_time
    ,tr.prev_fire_time
    ,tr.trigger_type
    ,ctr.cron_expression
    FROM ers_distributionoptions sch
    JOIN ers_reports rpt ON (sch.reportid = rpt.reportid)
    LEFT OUTER JOIN ejs_triggers tr ON (sch.schedulename = tr.trigger_name)
    LEFT OUTER JOIN ejs_cron_triggers ctr ON (sch.schedulename = ctr.trigger_name)
    ORDER BY sch.reportid
    ,sch.schedulename)
    WHERE trigger_name IS NULL
    Jason Beard
    Private
    Private
    Veteran Member
    (219 points)
    Veteran Member
    Posts:79


    Send Message:

    --
    10/13/2017 2:53 PM
    Dave -
    Are you on the latest LBI release? I know this was identified as being resolved in a recent update although I transitioned to a new client before the fix was applied.
    Jason Beard
    617-548-5568
    jabeard3@gmail.com
    Dave Curtis
    HRIS Lead
    University of Maryland Medical System
    Veteran Member
    (292 points)
    Veteran Member
    Posts:102


    Send Message:

    --
    10/14/2017 6:10 AM
    We are not on the most recent release yet.
    I know Greg said they were having the same issue and Infor had them upgrade their LBI and he said it did not seem to fix the issue. Not sure if Greg was upgrading to the most recent release or not - but we have put a possible upgrade on the 'table' for a future plan.

    For some reason - it does seem like the occurrence of disappearing schedules has increased over the past two months... ofcourse I have more users actively working as report admins now and more people than ever before are publishing and maintaining reports - so it may just be that we have more reports so it seems like the occurrences have increased.

    As we rely more and more on LBI for business data needs - these disappearing schedules become more and more embarrassing honestly. We are at a point where we are going to need someone looking at the possible report schedule issues every morning...
    Char
    Private
    Private
    Veteran Member
    (184 points)
    Veteran Member
    Posts:62


    Send Message:

    --
    10/14/2017 7:41 AM
    I'm more of a Crystal expert than LBI expert and I've not bothered to VPN to a client to check this but I thought of something you might look at regarding your issue. Could it be that the ID that was used to create the schedule has been removed from your system? Years ago, BOE had this issue and we encouraged users to create recurring instances under a generic ID. I also know a few years ago when I was actively administering an LBI server, when I published a report, I changed the owner to a generic ID for the same reason. I have very few clients who set up recurring instances in LBI so I've not experienced this issue but thought it might be worth looking at the owner of the schedule. Good luck.
    You are not authorized to post a reply.