PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 01/12/2017 12:15 PM by  Shannon S
PO100 Job Needs Recovery
 6 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Shannon S
Lead Application Analyst - Infor SCM
Private
Basic Member
(30 points)
Basic Member
Posts:20


Send Message:

--
01/12/2017 7:37 AM

    We had our PO100RQ job go into Needs Recovery this morning and are trying to understand the error we received. The error stated 'database deadlock on a non-restartable step.' Can anyone help with this error?

     

    Thanks,

    Shannon

    Lynne
    Application Specialist
    Covenant HealthCare
    Veteran Member
    (273 points)
    Veteran Member
    Posts:111


    Send Message:

    --
    01/12/2017 7:47 AM
    Shannon-
    We've had this issue for years. I logged an incident over a year ago, and went round and round w/ Infor about this. They were never able to resolve it and I got tired of the run around. They want to blame it on more than one PO100 or RQ500 running at the same time. We have never run them at the same time. I'm hoping this will get resolved in v10. Are you on 10?

    I had to write a process flow to check for jobs in recovery due to this happening frequently. Our processes are time dependent and this has helped get notification. We just recover it and move on. Not the best solution though.
    Shannon S
    Lead Application Analyst - Infor SCM
    Private
    Basic Member
    (30 points)
    Basic Member
    Posts:20


    Send Message:

    --
    01/12/2017 7:51 AM
    Thanks for your reply Lynne!

    Yes, we are on v10. We have had this happen on a few occasions, but normally due to downtime. I didn't see anything this morning that seemed off or would cause this error, so I was a little confused.

    We attempted to get AMS to inform us when jobs went into recovery, but not sure if they are working on that or not anymore? Could you possibly share your process flow for notifying you when jobs are in a needs recovery status?

    Thanks again for your response!
    Lynne
    Application Specialist
    Covenant HealthCare
    Veteran Member
    (273 points)
    Veteran Member
    Posts:111


    Send Message:

    --
    01/12/2017 8:05 AM
    Shannon- my process flow runs on v9, so you may need to do some tweaking for v10. We aren't that far yet, so I haven't been able to run it on 10.

    I don't see where I can upload an attachment, so if you give me your email, I can send it directly to you.
    Shannon S
    Lead Application Analyst - Infor SCM
    Private
    Basic Member
    (30 points)
    Basic Member
    Posts:20


    Send Message:

    --
    01/12/2017 8:19 AM
    Thanks so much! Just a start would be helpful, then we can definitely tweak as needed for the v10.

    My email is shannon.shoemaker@childrensal.org

    Thanks again for your help!
    JimY
    Private
    Private
    Veteran Member
    (1089 points)
    Veteran Member
    Posts:389


    Send Message:

    --
    01/12/2017 11:25 AM
    You might want to check out JT-478024 on the Infor Support site. It deals with this issue.
    Shannon S
    Lead Application Analyst - Infor SCM
    Private
    Basic Member
    (30 points)
    Basic Member
    Posts:20


    Send Message:

    --
    01/12/2017 12:15 PM
    Thanks Jim
    You are not authorized to post a reply.