PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 03/07/2017 11:23 AM by  SCMaster-jk2
Automate DME Call
 2 Replies
Sort:
You are not authorized to post a reply.
Author Messages
SCMaster-jk2
SCM Analyst
Private
Veteran Member
(240 points)
Veteran Member
Posts:100


Send Message:

--
06/16/2016 3:50 PM

    I tried to post this in the SysAdmin forum but I haven't gotten any responses and I was wondering if maybe you all might know:

    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Hi everyone,

    Not sure if this is the correct forum to post in but I'm trying to automate a query using Powershell. I'm having an issue with creating the url for the query though.

    URL below:

    https://__lawson-server__/sso/SSOSe...ssion=TRUE&_ssoOrigUrl=/servlet/Router/Data/Erp?KEYUSAGE=PARAM%26MAX=1000%26NOHEADER=TRUE%26OUT=CSV%26DELIM=%09%26NEXT=TRUE%26PROD=PROD%26FIELD=COMPANY%3BLOCATION%3BLOCATION.NAME%3BBINGRPDTL.BIN-SEQ%3BPREFER-BIN%3BITEM%3BREORDER-POINT%3BUOM%3BGL-CATEGORY%3BCHARGEABLE-FL%3BITEMMAST.MANUF-NBR%3BITEMMAST.DESCRIPTION%3BITEMMAST.DESCRIPTION3%3BITEMMAST.INVEN-MAJCL%3BTRACKING-FL%3BITEMSRC.VENDOR%3BITEMSRC.PURCH-FR-LOC%3BITEMMAST.USER-FIELD3%3BACTIVE-STATUS%3BITEMMAST.ICSEGMENT%3BITEMMAST.ICFAMILY%3BITEMMAST.ICCLASS%3BITEMMAST.ICCOMMODITY%26SELECT=LOCATION%3D749WH%26FILE=ITEMLOC%26SK1=749%26SK2=749WH%26SK3=210792%26

     

    I'm navigating to the URL but then I get an error saying: "Error: no protocol: /servlet/Router/Data/Erp?...[rest of url]" 

    If I login using the sso URL and then using the DME url, the file pulls just fine, only when I combine them do I get this error. I'm following the examples at this site: https://itlearnings.wordpress.com/tag/sso/

     

    Does anyone have any experience running scripts to automate queries? Unfortunately, I don't have access to use python/perl or other scripting languages so I'm limited to Powershell.


    Joe Carey
    Senior Accountant
    Vizient, Inc.
    Basic Member
    (16 points)
    Basic Member
    Posts:6


    Send Message:

    --
    03/04/2017 11:09 AM
    Do you still need an answer to this? Just guessing, but you might need to url encode some of the characters in the _ssoOrigUrl parameter.
    SCMaster-jk2
    SCM Analyst
    Private
    Veteran Member
    (240 points)
    Veteran Member
    Posts:100


    Send Message:

    --
    03/07/2017 11:23 AM
    Hey Joe - I actually sort of got this working. The problem was it would grab the first "page" of results and I couldn't figure out how to move to the next page.
    You are not authorized to post a reply.