PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 10/29/2014 7:51 PM by  David Britton
Workspace & IE Compatibility View
 7 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Mark Jorgenson
Private
Private
Basic Member
(23 points)
Basic Member
Posts:9


Send Message:

--
4/23/2014 8:40 PM

    My company is in the process of migrating from Lawson 9.0 to Lawson 10.0 with Workspace as the UI.  We have run into a problem after logging into Workspace where Internet Explorer gives us the dreaded "Microsoft Internet Explorer 7 on Windows is not supported" message.  Of course we are not running IE7 on our PC’s, most are running IE8.

    The problem is directly related to our corporate domain requirements for IE.  We have numerous web based applications that require the compatibility view (CV) setting in IE to be turned on.  Because of this, our domain is set up so that all internal web applications launch with that setting.  Infor Workspace however requires that CV not be turned on.  This quote is directly from Infor development via an Incident that I have opened with Infor Extreme Support: “
    It is mandatory to have the compatibility view turned off so we don't run our product in quirks mode. This is required for both our customers and internally as well”.

    According to my research there is a meta tag that can be used in web page development that will force IE to run the browser session without CV turned on, it is; meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" .  Lawson has this tag in their Workspace wrapper; however it is missing in the index.htm and home.htm that make up each users “home page”.  I reported this in the incident that I opened along with supporting material and they wrote a JT for it.

    My dilemma is that I need a workaround right away (immediately) and Infor Extreme Support has not been able to provide one.  Has anyone else run into this issue or can anyone offer a potential solution?

    John Henley
    Private
    Private
    Senior Member
    (9899 points)
    Senior Member
    Posts:3317


    Send Message:

    --
    4/23/2014 9:18 PM
    You're not the only one who is struggling with this one.
    In addition to the meta tag, you can control compatibility view using domain-based group policy options (GPOs).
    The first is the "Turn off Compatibility View" policy. This would be enabled so that users could not alter the compatibility view settings.
    Next would be the “Use Policy List of Internet Explorer Sites”.
    Any sites which the organization would require to use Compatibility mode would be listed in this policy explicitly.
    Thanks for using the LawsonGuru.com forums!
    John
    Mark Jorgenson
    Private
    Private
    Basic Member
    (23 points)
    Basic Member
    Posts:9


    Send Message:

    --
    4/24/2014 11:35 AM
    Thanks John. I had actually discussed that option with our Wintel team. We recently completed a Data Center migration project and the thought of having to track down all of the web applications across the enterprise is a daunting one for the new team.
    Jon Gustafson
    Private
    Private
    New Member
    (6 points)
    New Member
    Posts:4


    Send Message:

    --
    5/29/2014 6:30 PM
    We ran into this and the solution was actually an easy one ---- we set the Lawson URL to be a TRUSTED SITE. When we did this, it does not look at it as an intranet, so the setting of 'Display intranet sites in Compatibility View' does not affect Lawson.

    Jon
    Bob Canham
    Private
    Private
    Veteran Member
    (596 points)
    Veteran Member
    Posts:216


    Send Message:

    --
    6/16/2014 6:57 PM
    Did anyone find a solution for this? We've found that some of our users have our domain added to their Compatibility Views and these are users who access from personal workstations. It looks like there is a Meta X-UA-Compatible IE=8 setting when I check developer tools, but it still says not supported when accessing S3.
    TBonney
    Private
    Private
    Veteran Member
    (640 points)
    Veteran Member
    Posts:276


    Send Message:

    --
    7/1/2014 11:15 AM
    What we have found to be problematic is that when you add the Lawson site to your list of compatibility view sites, it only remembers the list for your current IE session. Once you close that browser window and open a new one, you once again need to add the site(s) to the list.

    So, what we have considered doing is to utilize GPO to set IE to Standards Mode. Deployment seems that it will be limited to Citrix however, meaning anyone accessing Lawson locally will still need to deal with compatibility view on their own. Has anyone found any solution to a global distribution of the GPO policies, without having to apply and deploy the policy through a dedicated "Lawson" Citrix application/icon?

    Thank you.
    Marilyn Sizemore
    Private
    Private
    (9 points)
    Posts:3


    Send Message:

    --
    7/15/2014 10:32 PM
    With our new 10x install, I'm running into the same issue. My network engineer has a fix, but I'm wondering if Infor support is going to fix this instead of having to update GPO policies.

    Does anyone know the KB / JT for this so I can follow progress?

    Thanks..Marilyn C. Sizemore
    David Britton
    Private
    Private
    Veteran Member
    (129 points)
    Veteran Member
    Posts:53


    Send Message:

    --
    10/29/2014 7:51 PM
    We are in the middle of upgrading to Infor 10 / Mingle Foundation with IPA.
    The Inbasket does not work correctly under IE8 but the Meta tag sets the page to IE8:
    meta http-equiv='X-UA-Compatible' content='IE=8'

    On IE9, IE10 and IE11 you can go to Developers Tools and set the page to run as 9 or above (depending on your IE version) and
    The inbasket does display correctly.

    Only Infor could deliver a site where it forces the page to run in IE8 mode, but at the same time code the page so it will not run under IE8.
    You are not authorized to post a reply.