PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 07/19/2017 3:29 PM by  Roger French
Design Studio Form JS Not Working After Migrating To V10
 1 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Joe O'Toole
Private
Private
Veteran Member
(793 points)
Veteran Member
Posts:309


Send Message:

--
07/19/2017 10:45 AM

    We have a custom DS form based on HR11 that has some JavaScript added to the XML file to support features to open/view a PDF document, click an acknowledgment and perform an update to the Employee table to record the event.

    After migrating the form from S3 V9 to V10, the form and buttons do not work.

    While running as preview in DS using IE11 Developer Mode (with personality set to IE10) I am seeing an error that the "on click" function I have coded is not defined (although it is clearly in the code).

    It appears V10 interprets inserted JS code and functions differently.

    Has anyone encountered this and if so what is the workaround?

    Thanks.

    Roger French
    Private
    Private
    Veteran Member
    (1282 points)
    Veteran Member
    Posts:532


    Send Message:

    --
    07/19/2017 3:29 PM

    Joe - Is there any way you can apply the customizations from V9 to a fresh V10 HR11 form? Or are the customizations too integrated inside the form?

    I'm assuming you also rebuilt forms index and set custom productline?

    I have migrated other non-HR11 DS forms from V9 to V10 but I started from the fresh V10 form first. Yes there are differences in the underlying V10 forms compared to the V9 forms.

    You are not authorized to post a reply.