PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 5/3/2012 4:09 PM by  Mark F. Hardy
IE9
 10 Replies
Sort:
You are not authorized to post a reply.
Author Messages
kdcoate
Veteran Member
(114 points)
Veteran Member
Posts:44


Send Message:

--
4/17/2012 1:30 PM
    We are currently on LSF 9.0.1.4 and are getting ready to upgrade our desktop image to use IE9 (from IE7).  We don't have any Landmark applications.  Has anyone experienced issues with IE9?  We're developing a test plan and including any known issues would certanly help!

    Thanks!
    Greg Moeller
    Private
    Private
    Veteran Member
    (4123 points)
    Veteran Member
    Posts:1471


    Send Message:

    --
    4/17/2012 5:21 PM
    Lawson doesn't support IE9 until (I believe) LSF9.0.1.8 .. We tried IE9 with our 9.0.1.7 code, and the bottom left messages "Change Complete. Continue" etc. do NOT appear. This is apparently a big issue for some folks. You'll notice some buttons/labels appear differently too. Print Manager, esp.. the buttons will be prefaced by "lbl" ...

    Everything seems to still work correctly, just odd differences. The two issues I describe are some of the biggest that we've noticed.
    John Henley
    Private
    Private
    Senior Member
    (9893 points)
    Senior Member
    Posts:3315


    Send Message:

    --
    4/17/2012 5:33 PM
    Both of these issues can be overcome by changing the browser settings.
    Thanks for using the LawsonGuru.com forums!
    John
    Greg Moeller
    Private
    Private
    Veteran Member
    (4123 points)
    Veteran Member
    Posts:1471


    Send Message:

    --
    4/17/2012 6:07 PM
    John: Can I ask you to elaborate? I've followed Lawson KB article on how they want the settings. Even opened a call with GSC, and they were unable to help get IE9 functional.
    Greg Moeller
    Private
    Private
    Veteran Member
    (4123 points)
    Veteran Member
    Posts:1471


    Send Message:

    --
    4/17/2012 6:12 PM
    Note: Updating our test environment to LSF 9.0.1.9 fixed the IE9 issues without any changes to browser settings - beyond the Lawson recommendations. (*We just need to get 9019 in prod)
    John Henley
    Private
    Private
    Senior Member
    (9893 points)
    Senior Member
    Posts:3315


    Send Message:

    --
    4/17/2012 6:50 PM
    Change Internet Options
    Make sure the Lawson site is in the “trusted sites” for the browser.

    For IE7 and higher, there is a browser setting ("Allow status bar updates via script") you need to change.
    Thanks for using the LawsonGuru.com forums!
    John
    Attachments
    John Henley
    Private
    Private
    Senior Member
    (9893 points)
    Senior Member
    Posts:3315


    Send Message:

    --
    4/17/2012 6:50 PM
    For the "lbl" issue, one solution I have found that works is to add a "X-UA-Compatible" host header (via the web server) that forces downgrade in compatibility mode to IE8.


    Thanks for using the LawsonGuru.com forums!
    John
    Greg Moeller
    Private
    Private
    Veteran Member
    (4123 points)
    Veteran Member
    Posts:1471


    Send Message:

    --
    4/17/2012 7:14 PM
    For the "lbl" issue, I can see that working. With pre9018 LSF code, though even though we had the lawson site in the trusted list and changed the setting to allow status bar updates via script set, IE9 wouldn't display the messages.
    John Henley
    Private
    Private
    Senior Member
    (9893 points)
    Senior Member
    Posts:3315


    Send Message:

    --
    4/17/2012 7:28 PM
    I *think* but can't swear that I had it working with 9.0.1.5 as long as we used compatibility mode.
    Thanks for using the LawsonGuru.com forums!
    John
    kdcoate
    Veteran Member
    (114 points)
    Veteran Member
    Posts:44


    Send Message:

    --
    4/24/2012 4:46 PM
    Thanks for the info John & Greg. I don't have much control over the upgrade schedule but I can definitely pass along the concerns.
    Mark F. Hardy
    Sr Application Developer
    Bluegreen Corporation
    Veteran Member
    (124 points)
    Veteran Member
    Posts:44


    Send Message:

    --
    5/3/2012 4:09 PM
    I was having the issue of the messages not displaying.  I contacted Lawson Support.  They suggested KB #550047.  I verified all three tasks.  The last task, verify Status Bar enable in Internet Explorer, the status bar showed - it worked.
    You are not authorized to post a reply.