PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 10/05/2012 9:03 AM by  Kyric
LSO Certificate Issue
 5 Replies
Sort:
You are not authorized to post a reply.
Author Messages
pmeckes
Private
Private
Basic Member
(48 points)
Basic Member
Posts:24


Send Message:

--
09/28/2012 8:50 AM
    Steps that did not work....note used openssl to create self signed cert server.company.com

    1. Export the Server Information from the LSO application, creating the
    JADECONFIG file
    2. Open SignTool, Select the JADECONFIG file for the installation point
    3. Using SignTool, create a new self signed certificate
    4. Use the newly created self signed certificate, sign the JADECONFIG file
    5. Import the resulting JADEINSTALL file in to the LSO using Import
    Installation Point

    To install the client

    1. Open IE and go to the https://lso-server.hcsc.org:19006/grid/info.html
    link
    2. When presented with certificate warning page, click on the "continue to
    this website" link
    3. When the grid information page is presented, click on the Certificate
    Error box and View Certificates
    4. Go to the Certificate Path tab, click on the Root Certificate, Click the
    View Certificate Button
    5. Install the root certificate into the "Trusted Root Certification
    Authorities, Local Computer" Physical location

    The issue that we are having is that when we get to the Client Install step
    2, that page just re-appears and the grid information page is never
    presented
    Eklind
    Architect
    Lawson Software
    Veteran Member
    (114 points)
    Veteran Member
    Posts:38


    Send Message:

    --
    10/01/2012 12:32 AM
    Verify that the Grid is correctly up and running by using the link http://lso-server.hcsc.org:19005, the grid info page should be shown on http instead of https. If that is working open one idea is to add the site to the Trusted sites list in Internet Explorer and try again (instruction at the end).

    This is OK in a temporary environment but when letting on real users make sure to push out your root certificate to all clients before starting to install. There is a knowledgebase article at mylawson.com with ID 5411565 that containe some useful information about certyificates and Smart Office.

    Instructions:
    Open up Internet Options in Internet Explorer, switch to the Security tab, select Trusted sites and click on Sites button. Type in the url https://lso-server.hcsc.org:19006 and press Add. Press OK and OK. Try again.
    pmeckes
    Private
    Private
    Basic Member
    (48 points)
    Basic Member
    Posts:24


    Send Message:

    --
    10/01/2012 8:30 AM
    Still didn't work. The grid page looks fine. Notes - windows 2008 r2 server is not part of a domain. Computer name is LSO-SERVER. So the certificate was created for lso-server.hcsc.org Does that matter ? IE is version 8 - so the error says 'IE can't display the page' it never gets to the continue anyway.....
    pmeckes
    Private
    Private
    Basic Member
    (48 points)
    Basic Member
    Posts:24


    Send Message:

    --
    10/02/2012 8:36 AM
    I upgraded IE8 to IE9, now I get the website security screen, but when I click continue to this website nothing happens.
    It's probably a certificate issue, but what ?
    Eklind
    Architect
    Lawson Software
    Veteran Member
    (114 points)
    Veteran Member
    Posts:38


    Send Message:

    --
    10/04/2012 2:35 AM
    I have not seen this kind of behaviur before. What version of Grid are you using?
    Kyric
    Lawson System Administrator
    SMRC
    Basic Member
    (40 points)
    Basic Member
    Posts:14


    Send Message:

    --
    10/05/2012 9:03 AM
    Run mmc and add Certificate add ins. go to trusted Root cert auth and import the cert their. You may need to import two certficate one for grid and the certificate you created. Try opening IE as administrator as well.
    You are not authorized to post a reply.