PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 5/11/2016 6:08 PM by  Todd Mitchell
User Token Security in Lawson 10
 4 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Todd Mitchell
Senior IT Specialist
Gordon Food Service
Veteran Member
(207 points)
Veteran Member
Posts:87


Send Message:

--
5/11/2016 11:38 AM

    We are upgrading to Lawson 10 and in our testing via Portal (Ming.le) we (the developers and the business users) are not able to access or create jobs that include User tokens.   i have reviewed the Lawson Security Administrator and the tokens are there and assigned to a security class that the user has been granted.  I added an Environment token via the multi-step job (just to verify I could add other tokens) and that worked.

    Any ideas on what may be missing in our environment or security setup?

    Dave Amen
    Private
    Private
    Veteran Member
    (209 points)
    Veteran Member
    Posts:75


    Send Message:

    --
    5/11/2016 11:47 AM
    Morning Todd,
    A couple of things to check:
    - In pgmdef, do all of these programs have "In Production On" set to Unix or NT?

    - Do the users have security access to the system code(s) containing these programs?

    Regards,
    Dave
    (303) 773-3535
    Todd Mitchell
    Senior IT Specialist
    Gordon Food Service
    Veteran Member
    (207 points)
    Veteran Member
    Posts:87


    Send Message:

    --
    5/11/2016 11:54 AM

    Hi Dave, 

    Long time no see.  

     

    This are tokens set up via TOKENDEF, not PGMDEF.

     

     

    Todd Mitchell
    Senior IT Specialist
    Gordon Food Service
    Veteran Member
    (207 points)
    Veteran Member
    Posts:87


    Send Message:

    --
    5/11/2016 12:52 PM

    Thanks for the phone call Dave.  I turned on logging and was able to see a potential issue.  The security class I thought I gave myself does not show up in the log.  I do see the one for our AR custom tokens and am able to add them.  So.... we are now tracking down the PR user tokens.

     

    Thanks again for the call.

     

     

    Todd Mitchell
    Senior IT Specialist
    Gordon Food Service
    Veteran Member
    (207 points)
    Veteran Member
    Posts:87


    Send Message:

    --
    5/11/2016 6:08 PM

    Turns out the issue was in how we assigned the security class to the Role.  Was set up as an APP instead of ENV.  Made that change and it now works.

     

     

    You are not authorized to post a reply.