PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 01/16/2014 11:19 AM by  Lorraine
Uploading Budgets (FB20.1) using Add-Inns
 7 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Saurabh
Private
Private
Veteran Member
(216 points)
Veteran Member
Posts:94


Send Message:

--
05/19/2010 6:45 AM
    All
    I am trying to create an upload routine to be allow the end users to Upload the Budget directly.
    Have been able to creat the Budget Header, but when trying to load the Budget detail (simulating FB20.1) keep getting "Field Is Required" errors. Have tried to look for any hidden fields etc but no luck.

    Has anybody tried to upload Budgets using Add-Inns and if so are willing to share/provide tips on same.

    We are on LSF9.0.0.4, 8.1 MSP5 on Win2003R2 with SQL back end.

    Regards
    Saurabh
    Tom Keller
    Advanced Member
    (96 points)
    Advanced Member
    Posts:42


    Send Message:

    --
    05/19/2010 8:38 AM
    To find what field is required chose "View the last Upload Query Sent" It is the icon at the top of the upload wizard that looks like a page with a magnifying glass. Copy the and paste the string into an open browser and scroll to the bottom of the code and the required fields will be listed.
    Saurabh
    Private
    Private
    Veteran Member
    (216 points)
    Veteran Member
    Posts:94


    Send Message:

    --
    05/19/2010 9:10 AM
    Hi Tom
    Thanks for the Tip. Wasnt aware of the functionality of that Icon. Will use that to debug the error
    regards
    Saurabh
    Saurabh
    Private
    Private
    Veteran Member
    (216 points)
    Veteran Member
    Posts:94


    Send Message:

    --
    05/20/2010 8:34 AM
    Found the issue using the Tip above.
    Had missed the "Fiscal Year" field for the budget.
    The budget has now loaded.
    Many thanks to everyone who responded
    regards
    Saurabh
    Tom Keller
    Advanced Member
    (96 points)
    Advanced Member
    Posts:42


    Send Message:

    --
    05/20/2010 8:38 AM
    WooHoo
    TDB
    New Member
    (4 points)
    New Member
    Posts:2


    Send Message:

    --
    01/09/2012 3:26 PM
    Hi,
    I am having a similar problem.  This is the string that I am having trouble with


    Transaction/Erp?_PDL=PROD&_TKN=AM30.1&_EVT=ADD&_RTN=DATA&_TDS=IGNORE&FC=Add&_ADDINS=TRUE&_f1=A&_f5=40571&_f10=&_f13=&_f14=F&_f39=200&_f43=&_f44=&_f45=200%2D155&_f47=&_f48=&_f49=&_f50=200%2D01&_f72=FF%2DAND%2DE&_f73=DOCK%20TRK&_f75=STANDARD&_f77=121550001&_f79=12155&_OUT=XML&_EOT=TRUE

    From what you posted previously would I be correct in saying that everytime there is an '&' symbol it is signifying another required field?  And if this is true then does that mean that my upload will not work unless all of these fields are filled in with some sort of values?
    Thanks

    Saurabh
    Private
    Private
    Veteran Member
    (216 points)
    Veteran Member
    Posts:94


    Send Message:

    --
    01/10/2012 3:44 AM
    You will need all the mandatory fields to be in the upload string. Its possible you are missing a field which is causing your script to fail.
    Lorraine
    Commercial Accountant
    Private
    Basic Member
    (10 points)
    Basic Member
    Posts:4


    Send Message:

    --
    01/16/2014 11:19 AM
    HI we are also trying to do the same thing but stumbling at the uwf file because there are insufficient fields for the amount of columns I need! How do we add extra fields on an addin generally? Have tried to google this so far to no avail...
    You are not authorized to post a reply.