PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 04/17/2020 3:36 PM by  Jay2
List-based Sync won't run!
 11 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Dave Amen
Private
Private
Veteran Member
(197 points)
Veteran Member
Posts:71


Send Message:

--
04/02/2020 7:52 PM

    I've seen list-based sync run on Unix, but never on a Windows server.

    When I attempt to run it, I've tried putting the full path in, the partial path, being in the same folder as the file, but it simply won't find it
    (even though I can see the file right there):

    D:\lsftest\launt\UCH_lawson> ls -l TinyTest.xml
    -rwxrwxrwa   1 UCH\lawson       UCH\Domain Users        349 Apr 01 TinyTest.xml
     

    D:\lsftest\launt\UCH_lawson> ssoconfig -S ssocpassword TinyTest.xml
    File with this name doesn't exist. Exiting...
    D:\lsftest\launt\UCH_lawson>

    Any thoughts?

     

    Subsequent question: does anyone know if List-based Sync is anywhere in the ssoconfig menu options?
    That may be another way to approach it.

    jdever
    Senior Infor/Lawson Consultant
    Southeast ERP, LLC
    Advanced Member
    (73 points)
    Advanced Member
    Posts:29


    Send Message:

    --
    04/03/2020 4:09 PM

    I had a similar issue...

    The list based sync command no longer needs a password.  So the command is looking for a file that is your password.

    Try ssoconfig -S TinyTest.xml
    <!--[if !supportLineBreakNewLine]-->
    <!--[endif]-->

     

    Dave Amen
    Private
    Private
    Veteran Member
    (197 points)
    Veteran Member
    Posts:71


    Send Message:

    --
    04/03/2020 4:48 PM
    Thanks, jdever. Your info is great!
    (and a bit scary with no password)
    But I'm still getting a similar error:
    ssoconfig -S TinyTest.xml
    SYNC_STATUS=false
    SYNC_STATUS_MESSAGE=Error occurred in performing backgr
    ound sync due to Error reading file TinyTest.xml due to exception. Make sure tha
    t TinyTest.xml exist. Details TinyTest.xml (The system cannot find the file spec
    ified) Please check logs for complete details.


    I checked the security_provisioning.log file, and it's the same message (cannot find the file).
    I copied it to simpler names, put in the path, but still the same thing.
    But this seems to be getting closer!
    TJ Mann
    Private
    Private
    Veteran Member
    (107 points)
    Veteran Member
    Posts:43


    Send Message:

    --
    04/09/2020 5:07 PM

    i ran into this issue once or twice. check your WAS application server to look for hung PID. i had to recycle 1 of 3 WAS to resolve my 1st time issue. 2nd time, i had recycle lawson. last, stop all lawson services, and rename %LAWDIR%/system/derbydb, and restart all services again. you will see new derbydb. good luck.

    Dave Amen
    Private
    Private
    Veteran Member
    (197 points)
    Veteran Member
    Posts:71


    Send Message:

    --
    04/15/2020 5:21 PM
    Hi TJ,
    I don't have access to those, but I'm endeavoring to get what you suggested done.
    Thanks!
    Jay2
    Private
    Private
    Veteran Member
    (192 points)
    Veteran Member
    Posts:84


    Send Message:

    --
    04/15/2020 10:21 PM

    Jdever was close. You don’t need the password but you do need the full path even if you are in the correct directory.

    D:\lsftest\launt\UCH_lawson> ssoconfig -S D:\lsftest\launt\UCH_lawson \TinyTest.xml

    Jay2
    Private
    Private
    Veteran Member
    (192 points)
    Veteran Member
    Posts:84


    Send Message:

    --
    04/16/2020 9:41 AM
    Subsequent question: does anyone know if List-based Sync is anywhere in the ssoconfig menu options?
    That may be another way to approach it.

    Yes it is option 14 and then option 1 but again you need to use full path when calling the file.
    Dave Amen
    Private
    Private
    Veteran Member
    (197 points)
    Veteran Member
    Posts:71


    Send Message:

    --
    04/16/2020 10:47 PM

    Getting closer!
    First, I've been trying it with and without the full path since the beginning - that didn't help.

    Jay2 - I think you had a typo with two backslashes which you subsequently corrected, but that reminded me of something I've seen with Windows.
    This command gets the closest so far (double-backslashes):
             ssoconfig -S D:\\lsftest\\launt\\UCH_lawson\\TinyTest.xml

    That foound the file(!), and then returned this:
    SYNC_STATUS_MESSAGE=Error occurred in performing background sync due to A background synchronization process is already in progress. Cannot start the requested BACKGROUNDSYNCHRONIZATION before finishing. Please check logs for complete details.

    There are lots of messages in security_provisioning.log and security_FedSummary.log - I'm digging through them.

    For those interested and helping, thank you, and stay tuned!

    jdever
    Senior Infor/Lawson Consultant
    Southeast ERP, LLC
    Advanced Member
    (73 points)
    Advanced Member
    Posts:29


    Send Message:

    --
    04/17/2020 7:53 AM

    That tells me that you got your command working.

    In ssoconfig -c there is an option that will allow you to unlock/cancel the ongoing sync. The option numbers 12 or  20 stick in my mind,

    You then choose the process to cancel.  If there are no processes to cancel, then the screen flashes and comes back to the menu.  So after cancelling a process, I always try the menu item again.... it should flash and stay on the menu...then exit ssoconfig.

    Good luck.

     

    Jay2
    Private
    Private
    Veteran Member
    (192 points)
    Veteran Member
    Posts:84


    Send Message:

    --
    04/17/2020 9:44 AM
    If you go into ISS under federation you can manage locked processes. Unlock the process. After the lock clears try your command again.
    Dave Amen
    Private
    Private
    Veteran Member
    (197 points)
    Veteran Member
    Posts:71


    Send Message:

    --
    04/17/2020 10:09 AM
    jdever and Jay2,
    I tried the command this morning before looking into stuck processes, and it appears to have worked!

    SYNC_STATUS=true
    SYNC_STATUS_MESSAGE=Background [List Based] sync process started.

    The ISS sync hasn't worked at this company for years and they're not interested in addressing that - thus the list-based sync, which I need to run for 300 employees out of their 20K. I'll verify the results as soon as I can, but I may come back here if the XML doesn't work as I think it should.

    Thanks so much for all of the help, especially what I assume was your typo, Jay2!
    Jay2
    Private
    Private
    Veteran Member
    (192 points)
    Veteran Member
    Posts:84


    Send Message:

    --
    04/17/2020 3:36 PM
    Some of the simplist solutions are found through mistakes. :-)
    You are not authorized to post a reply.