PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 5/20/2009 3:16 PM by  Jimmy Chiu
Form Help in HR11
 3 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Ronald
Private
Private
Basic Member
(42 points)
Basic Member
Posts:24


Send Message:

--
5/1/2009 4:51 PM

    We are having trouble with Form Help in HR11 in Portal.  Form Help works in other applications but HR11.  We did go through LID and that worked, however using Form Help in HR11 does not work at all.

     

    Any ideas. 

    This has stumped Lawson Support also.

    Buddy Miller
    Private
    Private
    New Member
    (6 points)
    New Member
    Posts:2


    Send Message:

    --
    5/6/2009 11:56 AM

    Have you tried to clear the HR11.hlp file and rebuild it?  Normally located in $LAWDIR/productline/map/default/ (at least on 8.0.3 and 9.0.0). 

    I would remove all the HR11 files there (.xml, .hlp, and .trm) then recreate using them using qcompile.

    Buddy Miller

    Jimmy Chiu
    System Analyst
    Federal Government
    Veteran Member
    (1880 points)
    Veteran Member
    Posts:640


    Send Message:

    --
    5/8/2009 7:54 PM

    Look under your LAWDIR/help/*language*/*productline* /HR11_1.xml

    the size of the file probably is 0kb, thus form help doesnt work.

    I don't know why that is, when i install the application help from lawson, I discovered alot of 0kb xml help files. any program with 0kb xml help files won't display form help in portal.

    To work around portal form help missing, copy the HR11.1.xml from LAWDIR\*productline*\map\default to LAWDIR\help\*language*\*productline*\HR11_1.xml

     

    Jimmy Chiu
    System Analyst
    Federal Government
    Veteran Member
    (1880 points)
    Veteran Member
    Posts:640


    Send Message:

    --
    5/20/2009 3:16 PM
    After further examining the blank form help problem. I have discovered the XML help files have an error tag causing the form help to hang.

    Looking under your portal help XML files folder. %LAWDIR%\help\en-us\productline

    remove greaterthansign !DOCTYPE lawsonhelp PUBLIC "-//Arbortext//DTD Composer 1.0//EN" "../doctypes/composer/composer.dtd" smallerthansign

    save and IOS cache refresh, then the form help will work correctly.
    You are not authorized to post a reply.