PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 09/14/2019 6:16 PM by  Kwane McNeal
Error on importdb
 4 Replies
Sort:
You are not authorized to post a reply.
Author Messages
JonA
Private
Private
Veteran Member
(3111 points)
Veteran Member
Posts:1097


Send Message:

--
09/14/2019 3:09 PM

    Trying to importdb to ITEMLOC and getting this error.

     

    importdb -afu test10 itemloc ITEMLOC.csv

    ' Does Not ExistE-COST

    Jon Athey - Supply Chain Analyst - Materials Management - MidMichigan Health
    Ragu Raghavan
    Private
    Private
    Veteran Member
    (999 points)
    Veteran Member
    Posts:347


    Send Message:

    --
    09/14/2019 3:27 PM
    It seems to be erroring out on a column named E-COST. Do have have such a column on the file ITEMLOC.csv?
    JonA
    Private
    Private
    Veteran Member
    (3111 points)
    Veteran Member
    Posts:1097


    Send Message:

    --
    09/14/2019 3:39 PM

    No I don't.  This is the first few lines of the file.

     

    COMPANY,LOCATION,ITEM,AVERAGE_COST,LAST_REC_COST,LAST_ISS_COST
    10,WBR,92013,387.301,387.301,387.301
    10,WBR,119791,334.7,334.7,334.7
    10,WBR,10312,321.52,321.52,321.52
    10,WBR,22596,298.35,298.35,298.35
    10,WBR,93785,297.91,297.91,297.91
    10,WBR,119836,217.55,217.55,217.55
    10,WBR,119965,211.58,211.58,211.58
    10,WBR,62936,200,200,200
    10,WBR,86180,194.48,194.48,194.48

    Jon Athey - Supply Chain Analyst - Materials Management - MidMichigan Health
    Ragu Raghavan
    Private
    Private
    Veteran Member
    (999 points)
    Veteran Member
    Posts:347


    Send Message:

    --
    09/14/2019 3:52 PM
    I do not think underscores are allowed. try changing AVERAGE_COST to AVERAGE-COST and replacing all other undercores by hyphens
    Kwane McNeal
    Private
    Private
    Veteran Member
    (1323 points)
    Veteran Member
    Posts:441


    Send Message:

    --
    09/14/2019 6:16 PM
    It’s getting E_COST from averagE_COST, the first field with the underscore.
    Raghu is correct, underscores are not valid in field names
    You are not authorized to post a reply.